Экзаменационная работа по информатике в формате ОГЭ 9 класс

Инструкция по выполнению работы

На выполнение экзаменационной работы по информатике отводится 45 минут. Работа состоит из 2 частей, включающих в себя 12 заданий. При выполнении работы нельзя пользоваться компьютером, калькулятором, справочной литературой.

Часть 1 включает 5 заданий (1–5) с выбором ответа. К каждому заданию даётся четыре варианта ответа, из которых только один верный. При выполнении этих заданий обведите кружком номер выбранного ответа в экзаменационной работе. Если Вы обвели не тот номер, то зачеркните этот обведённый номер крестиком, а затем обведите номер правильного ответа.

Часть 2 включает 7 заданий (6–12) с кратким ответом. Для заданий части 2 ответ записывается в работе в отведённом для этого месте. В случае записи неверного ответа зачеркните его и запишите рядом новый.

Все задания экзаменационной работы соответствуют формату заданий ОГЭ.

При выполнении заданий Вы можете пользоваться черновиком.

Баллы, полученные Вами за выполненные задания, суммируются. Постарайтесь выполнить как можно больше заданий и набрать наибольшее количество баллов.

Итоговая контрольная работа по информатике 9класс

Часть 1.

А1. Для какого из приведённых имён истинно высказывание:

НЕ (Первая буква гласная) И НЕ (Последняя буква согласная)?

1) Татьяна

2) Роман

3) Олег

4) Анна

А2. Пользователь находился в каталоге Расписание. Сначала он поднялся на один уровень вверх, затем ещё раз поднялся на один уровень вверх, потом спустился на один уровень вниз. В результате он оказался в каталоге

С:\учёба\математика\ГИА.

Укажите полный путь каталога, с которым пользователь начинал работу.

1) С:\учёба\Расписание

2) С:\учёба\2013\Расписание

3) С:\учёба\математика\Расписание

4) С:\учёба\математика\2013\Расписание

А3. Между населёнными пунктами А, В, С, D, Е построены дороги, протяжённость которых (в километрах) приведена в таблице:

А

В

С

D

E

А

3

7

В

3

2

8

С

7

2

4

D

4

1

E

8

1

Определите длину кратчайшего пути между пунктами А и E. Передвигаться можно только по дорогам, протяжённость которых указана в таблице.

1) 9

2) 10

3) 11

4) 12

A4. Дан фрагмент электронной таблицы:

A

B

C

D

1

2

4

6

8

2

=D1/B1

=D1-B1

=А1+2

Какая из формул, приведённых ниже, может быть записана в ячейке D2, чтобы построенная после выполнения вычислений диаграмма по значениям диапазона ячеек A2:D2 соответствовала рисунку?

1) =А1-1

2) =С1+В1

3) =С1+1

4) =С1/3

А5. Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b — целые числа), перемещающую Чертёжника из точки с координатами (x, у) в точку с координатами (x + а, у + b). Если числа a, b положительные, значение соответствующей координаты увеличивается; если отрицательные, уменьшается.

Например, если Чертёжник находится в точке с координатами (4, 2), то команда Сместиться на (2, −3) переместит Чертёжника в точку (6, −1).

Запись

Повтори k раз

Команда1 Команда2 КомандаЗ

Конец

означает, что последовательность команд Команда1 Команда2 КомандаЗ повторится k раз.

Чертёжнику был дан для исполнения следующий алгоритм:

Повтори 3 paза

Команда1 Сместиться на (3, 2) Сместиться на (2, 1) Конец

Сместиться на (−9, −6)

После выполнения этого алгоритма Чертёжник вернулся в исходную точку. Какую команду надо поставить вместо команды Команда1?

1) Сместиться на (−6, −3)

2) Сместиться на (4, 3)

3) Сместиться на (−2, −1)

4) Сместиться на (2, 1)

Часть 2.

В1. В одном из изданий книги М.А. Булгакова «Мастер и Маргарита» 256 страниц. Какой объём памяти (в Мбайтах) заняла бы эта книга, если бы Михаил Афанасьевич набирал её на компьютере и сохранял текст в одном из представлений Unicode, в котором каждый символ занимает 16 бит памяти? На одной странице помещается 64 строки, а в строке 64 символа.

Ответ:______________

В2. Переведите число 147 из десятичной системы счисления в двоичную систему счисления. Сколько нулей содержит полученное число? В ответе укажите одно число — количество значащих нулей.

Ответ:______________

В3. На рисунке изображена схема дорог, связывающих города A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города A в город G?

Ответ:______________

В4. В программе «:=» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – операции сложения, вычитания, умножения и деления, «div» целочисленное деление, «mod» взятие остатка от деления. Правила выполнения операций и порядок действий соответствует правилам арифметики.

Определите значение переменной а после выполнения данного алгоритма:

a := 17

b := 3

b := a mod b + 5

a := 25 — a div b

В ответе укажите одно целое число – значение переменной а.

Ответ:______________

В5.Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык Бейсик Паскаль
алг

нач

цел s, k

s:=0

нц для k от 3 до 10

s:=s+13

кц

вывод s

кон

DIM s,k AS INTEGER

s = 0

FOR k = 3 TO 10

s= s+13

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s:=0;

for k:=3 to 10 do

s:=s+13;

write(s);

End.

Ответ:______________

В6. Доступ к файлу edu.txt, находящемуся на сервере htm.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы буквами от А до Ж. Запишите последовательность этих букв, кодирующую адрес указанного файла в сети Интернет.

А) htm

Б) ://

В) /

Г) http

Д) .ru

Е) .txt

Ж) edu

Ответ:________________________

В7. В таблице приведены запросы к поисковому серверу. Для каждого запроса указан его код – соответствующая буква от А до Г. Расположите коды запросов слева направо в порядке возрастания количества страниц, которые нашёл поисковый сервер по каждому запросу. По всем запросам было найдено разное количество страниц.

Для обозначения логической операции «ИЛИ» в запросе используется символ «|», а для логической операции «И» – «&».

Код

Запрос

А

Солнце | Воздух | Вода

Б

Солнце & Воздух & Вода

В

(Солнце | Воздух) & Вода

Г

Солнце | Воздух

Ответ:______________

Экзаменационная работа по информатике

9класс

Ответы

А1 1
А2 4
А3 3
А4 4
А5 1
В1 2
В2 4
В3 7
В4 23
В5 104
В6 ГБАДВЖЕ
В7 БВГА

 

Добавить комментарий

Ваш e-mail не будет опубликован.