Программирование циклических алгоритмов (9 класс)

Проверочная работа содержит 7 заданий и предназначена для проверки результатов обучения по этой теме в 9 классе.

1. Какого оператора цикла не существует в языке Паскаль?
а) for
б) while
в) repeat…until
г) loop

2. Сколько раз будет исполнен цикл в фрагменте программы:
р:=2;
repeat
р:=р*0.1
until p<0.1;

а) 0 раз
б) 1 раз
в) 2 раза
г) бесконечное число раз

3. Сколько раз выполнится цикл в фрагменте программы:
а:=1;

b:=1;
while a+b<8 do
begin
a:=a+1;
b:=b+2
end;

а) 0 раз
б) 2 раза
в) 3 раза
г) бесконечное число раз

4. Определите значения переменных s и i после выполнения фрагмента программы:
s:=0; i:=5;
while i>0 do
begin
s:=s+i;
i:=i-1;
end
;
a) s = 0, i = -1
б) s = 5, i = 0
в) s = 15, i = 5
г) s = 15, i = 0

5. Выберите фрагмент программы, в котором ищется произведение 1*2*3*4*5.
a) p:=0; i:=1; while i<=5 do i:=i+1; p:=p*i;
б) p:=1; i:=1; while i<6 do i:=i+1; p:=p*i;
в) р:=1; i:=1; while i<6 do begin p:=p*i; i:=i+1 end;
г) p:=1; i:=1; while i>5 do begin p:=p*i; i:=i+1 end;

6. В данном фрагменте программы
s:=0;
for i:=1 to 10 do
s:=s+2*i;

вычисляется:
а) сумма целых чисел от 1 до 10
б) сумма чётных чисел от 1 до 10
в) удвоенная сумма целых чисел от 1 до 10
г) сумма первых десяти чётных чисел

7. Определите, что будет напечатано в результате работы следующей программы.
var s, k: integer;
begin
s := 60;
for k := 1 to 8 do
s := s – 4;
write(s);
end.

Ответ: _______________

 

Добавить комментарий

Ваш e-mail не будет опубликован.